Monday, November 22, 2010

DBAN *ERROR /dev/sda (process crash)

So I was using DBAN 2.2.6 beta to wipe the drives on a Dell PowerEdge 860. After typing "autonuke," DBAN would load, but instead of starting the wipe I would get these errors:

DBAN finished with non-fatal errors.
*ERROR /dev/sdb (process crash)
*ERROR /dev/sda (process crash)
Press and hold power button to shut down


When I loaded DBAN manually (by pressing enter at the boot prompt instead of typing "autonuke"), I would see an "unrecognized device" in the device list.

I finally figured out what it was: the DRAC had set up some kind of virtual drives. I had to go into the DRAC menu (Ctrl-D when it asks you at the boot prompt), page down until I saw the virtual drives, and then I pressed E to disable them. Once I did that, DBAN ran just fine.

Edit:
I just ran into this same problem on a Dell PowerEdge 1950, but it must have had a different DRAC version because the process of disabling of the virtual drives was a little different. I had to press Ctrl-E to get into the DRAC menu when it prompted me, then I had to arrow down to Virtual Media Configuration and change the Virtual media setting from attached to detached.

21 comments:

  1. I am having the same problem on my other computer. But I Don't know what the DRAC menu is. You said to press Ctrl-D when it asks at the boot prompt... I guess I just don't know what the boot prompt is. Please inform. And also what virtual drives did you disable? thanks

    ReplyDelete
  2. DRAC = Dell Remote Access Controller. Only Dell servers will have a DRAC, but not all come with DRACs. If you have a Dell server with a DRAC, at some point during the boot process (after the BIOS screen), it will prompt you to press Ctrl-D to load the DRAC configuration. I disabled all virtual drives in the DRAC; I think there was a virtual floppy and virtual CD-ROM.

    If that doesn't apply to you, the general solution seems to be to unplug/disable any non-essential drives. You might find these helpful:

    2988662 - DBAN finished with non-fatal errors
    SOLVED non-fatal errors / process crash

    ReplyDelete
  3. Glad I found this! Unfortunately I guess this means I won't be running DBAN mounted over DRAC...

    ReplyDelete
  4. Excellent post. I have been fighting this for a week and now I can use DBAN to clear the drives. Thank You

    ReplyDelete
  5. What if it's not on a server? I'm getting /dev/sda, /dev/sdb, and /dev/sdc errors and it's not on a server, it's on a Dell Precision T3500

    ReplyDelete
  6. Hey Mark,

    as I said in my comment above, the general solution seems to be to unplug/disable any non-essential drives and devices. in particular you should make sure there isn't anything plugged in to your USB ports (other than perhaps your keyboard) and you have no cards in your card reader. this also means that you may have to boot DBAN from a CD rather than a USB flash drive.

    see the links in my comment above for additional suggestions that might help.

    ReplyDelete
  7. Yeah, I have everything unplugged. My CD Drive, my floppy drive, all my USB devices except my keyboard and mouse, my second hard drive, and my printer. Nothing seems to be working.

    ReplyDelete
  8. just to clarify, your printer and second hard drive are disconnected, right? one of those links mentions some printers causing problems because they have card readers that are seen as drives by DBAN.

    essentially DBAN thinks you have 3 drives. so if you only have one, then somehow or other it's picking up 2 additional drives.

    I'd suggest checking those links. there are suggestions there ranging from disabling certain devices in BIOS to changing the internal ports your hard drives are connected to. the DBAN forums (http://sourceforge.net/projects/dban/forums) might be able to give you some more guided help.

    ReplyDelete
  9. I had the same problem with a non-dell-computer. The solution was to disable the USB-controller in BIOS (notice: usb-keyboard is also not working! So use a PS/2-keyboard). After deleting data you can enable them again. good luck!

    ReplyDelete
  10. [...] http://bmaupin.wordpress.com/2010/11/22/dban-error-devsda-process-crash/ [...]

    ReplyDelete
  11. I had the same problem except my computer doesn't have a ps/2 port for the keyboard, just USB. (it's an HP Pavilion Slimline running XP)
    So i went into the setup menu (press F10 at startup) and manually disabled all my usb ports except for the one the keyboard was plugged into. DBAN is now running smooth.

    ReplyDelete
  12. dban nousb

    Ignores usb drives, boots quicker and doesn't crash.

    ReplyDelete
    Replies
    1. You sir are a genius!!! dban nousb worked like a charm

      Delete
  13. I don't think this would have solved my problem, since it was specific to virtual drives on Dell servers, but this is a great tip for others running into this problem. Thanks!

    ReplyDelete
  14. [...] also had some unknown devices showing up so I disabled iDRAC media in the iDRAC [...]

    ReplyDelete
  15. Dell Inspiron 1545, internal HDD + bay DVD-RW (booting DBAN 2.26 beta off the UBCD, old-school, I know!)

    I get two 'drives' listed:

    ' [????] Unknown Device '
    [ ] (ONBOARD HARD DRIVE AS EXPECTED)

    Just started with ' dban nousb ' and got the ' Waiting for USB devices to register ', so it doesn't seem to be correct, or the right syntax...

    - Oh hold on, regardless of claiming to be searching for USB devices, it works now without the '[????] Unknown Device confused listing.

    Which must have been the onboard card-reader.
    I know I'm not a coder so don't know quite what it takes to integrate support for all such devices on the market, but iIt's a bit lame of the otherwise pretty solid DBAN to let this predictable USB card reader thing stand in its way...

    However, it's far more lame of Dell to offer no off-switch in their lame CMOS Setup program (which also has trouble enforcing it's own explicitly-set boot order: booting from CD, reliably, requires un-ticking everything but the DVD-RW drive in the boot list, - even though there's the usual option for selecting the order explicitly - and even with the F12 manually select boot device after the POST!

    Anyway, thanks for the easy fix in previous posts. Cheers!

    ReplyDelete
  16. Update, I had to use an external USB DVD-RW drive to boot the Dell Restore CDs, which is what I was preparing the drive for with DBAN. The worthless BIOS required removing the INTERNAL DVD-RW (which should have been fine to use alone, as should be obvious). The internal DVD-RW drive may be faulty, fussy (of very nicely-burnt DVD-Rs I may add), but even my ancient Athlon XP motherboard recognises and offers to boot from an external DVD-RW. Dell fail in this case. Anyone arriving here from Google, take note and beware in future laptop purchases.

    ReplyDelete
  17. Oh you beauty!!

    Been trying to work this out for a few days on and off. I would have never have thought of the DRAC

    Its Ctrl E on my servers but I can DBAN away now with all RAID arrays done at once.

    I love the internet, I'd marry it if it was female. Please no one ever tell the users, we'd be out of a job!

    ReplyDelete
  18. Great post and tip! This really fixed my problem.

    Now the DBAN is working as expected.

    Thanks a lot!
    Douglas.

    ReplyDelete
  19. Had the same issue. Fixed by using the NOUSB option, AND using DBAN 2.3.0 instead of 2.2.7.

    ReplyDelete